Cara Setting Loadbalancing mode NTH ( dual badwidth ) 100% Work

12Mar, 2017

Pada dasarnya Loadbalancing adalah metode penggabungan antara 2 atau lebih koneksi internet menjadi 1 management bandwidth yang dapat diatur atau disesuaikan sendiri sesuai kebutuhan.

Loadbalancing dibagi menjadi 2 mode yaitu NTH & PCC Load Balancing, dan disini kami akan membahas tutorial loadbalancing mode NTH,
Berikut adalah skema jaringan yang diterapkan untuk Loadbalancing ini

ISP1         = 192.168.1.1/24
ISP2         = 192.168.2.1/24
LOCAL    = 10.10.10.0/24

Pengaturan nama interface untuk memudahkan dalam mengelola jaringan.

/ip address
add address=10.111.0.2/24 interface=ISP1
add address=10.112.0.2/24 interface=ISP2
add address=10.10.10.1/24 interface=LOCAL

Konfigurasi DNS Server menggunakan DNS Google. Silakan gunakan DNS yang diberikan ISP masing-masing
/ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes max-udp-packet-size=512 cache-size=5000

Pengaturan disisi Mangle untuk NTH Loadbalancing, dan ini merupakan bagian yang terpenting untuk kesuksesan NTH Loadbalancing

/ip firewall mangle
add chain=prerouting in-interface=LOCAL connection-state=new nth=2,1 action=mark-connection new-connection-mark=Koneksi1 passthrough=yes
add chain=prerouting in-interface=LOCAL connection-mark=Koneksi1 action=mark-routing new-routing-mark=Koneksi1 passthrough=no
add chain=prerouting in-interface=LOCAL connection-state=new nth=2,2 action=mark-connection new-connection-mark=Koneksi2 passthrough=yes
add chain=prerouting in-interface=LOCAL connection-mark=Koneksi2 action=mark-routing new-routing-mark=Koneksi2 passthrough=no

Pengaturan Gateway dan pastikan Routing mark sesuai dengan IP Gateway masing-masing...

/ip route
add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=Koneksi1
add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=Koneksi2

Langkah terakhir konfigurasi NAT

/ip firewall nat
add chain=srcnat connection-mark=Koneksi1 action=masquerade out-interface=ISP1 disabled=no
add chain=srcnat connection-mark=Koneksi2 action=masquerade out-interface=ISP2 disabled=no

 

Notes :

  • Tidak disarankan untuk copy paste script karena biasanya sering mengalami kegagalan
  • Sebaiknya di lakukan langkah perlangkah, yaitu ISP1 dulu dikonfigurasi dan setelah jalan kemudian konfigurasi ISP2
  • Konfigurasi ini sudah di ujicoba dan berjalan dengan normal dan belum ada masalah sampai saat tulisan ini dibuat
  • Konfigurasi diterapakan menggunakan ISP yang berbeda, dan Bandwidth yang tidak sama

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

X